CDB description (CDBase Help)#
CDBase may be seen by the programmer as an unlimited number of sequential streams organized in the form of a linked list. Physically CDBase is formed by a direct access diskfile with a record length and a memory buffer to enhance IO-Operations. For parallel access an enhanced version using pvm is available. The system CDBase is optimized for typical FE-Analysis. Typically there exist large data volumes which are organized in a sequential manner. It is quite more often that data is changed than the data structure itself. That’s why some operations are NOT possible in CDBase.
In the programming interfaces in the ‘’CDBase Help’’, the main functions are described:
Open a database
sof_cdb_init()
Select a database
sof_cdb_use()
Flush a database
sof_cdb_flush()
Close a database
sof_cdb_close()
Get information
sof_cdb_status()
Set a lock
sof_cdb_lock()
Set a pvm mix-lock
sof_cdb_mix()
Remove a lock
sof_cdb_free()
Define relations
sof_cdb_kdel()
Inquire Index
sof_cdb_kenq()
Set a version
sof_cdb_putvers()
Get a version
sof_sof_getvers()
Existance of index
sof_cdb_kexist()
Inquire update status
sof_cdb_getupdate()
Get data
sof_cdb_get()
Put data
sof_cdb_put()
Rewind / explicit pos.
sof_cdb_rewind()
Decode text from integer values
sof_lib_ps2cs()